How to use Arduino Uno
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Typical Application

e Xoscillo, an open-source oscilloscope

e Arduinome, a MIDI controller device that mimics the Monome

e OBDuino, a trip computer that uses the on-board diagnostics interface found in most
modern cars

¢ Ardupilot, drone software and hardware

e Gameduino, an Arduino shield to create retro 2D video games

¢ ArduinoPhone, a do-it-yourself cellphone

e Water quality testing platform


https://en.wikipedia.org/wiki/Oscilloscope
https://en.wikipedia.org/wiki/Arduinome
https://en.wikipedia.org/wiki/MIDI_controller
https://en.wikipedia.org/wiki/Monome
https://en.wikipedia.org/wiki/OBDuino
https://en.wikipedia.org/wiki/Trip_computer
https://en.wikipedia.org/wiki/On-board_diagnostics
https://en.wikipedia.org/wiki/Ardupilot

Downloading / Installation

Go to www.arduino.cc to. download the latest version of arduino software and select your

operating isystem

On the Title bar Click on the Software Tab, Just scroll down once you will see this image

Download the Arduino IDE

ARDUINO 1.8.4

The open-source Arduino Software (IDE) makes it easy to
write code and upload it to the board. It runs on
Windows, Mac OS X, and Linux. The environment is
written in Java and based on Processing and other open-
source software.

This software can be used with any Arduino board.

Refer to the Cetting Started page for Installation
instructions.

©.0,

Windows Installer
Windows ZIP file for non admin install

Windows app

Mac OS X107 Lion or newer

Linux 32 bits
Linux 64 bits
Linux ARM

Release Notes
Source Code
Checksums (sha512)

According to your operating system, like if you have windows system then choose Windows

Installer.


http://www.arduino.cc/

Downloading / Installation
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}.':i:i setup () { ]
J/ put your setup code here, to run once:
}
wold loop() {
J/ put your main code here, to run repeatedly:
1
Y]

Arduino/Zenuine Uno on COM3



The Initial Set up

Select Tools menu and Board

Tools| Help
[

Auto Format Ctrl+T

| Archive Sketch

' Fix Encoding & Reload
Serial Monitor Ctrl+5Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 Firmware Updater

Board: "Arduing/Genuing Uno" ) SN CLICK HERE
Port L4

Get Board Info

Programmer: "AVRISP mikd" k

Burn Bootloader

Boards Manager...
Arduino AVRE Boards
Then select the type of Arduino board you want to Arduino Yiin
program, in our case it’s the Arduino Uno. & | Arduino/Genuino Uno
Arduino Duemilanove or Diecimila
Arduine Mano
Arduino/Genuine Mega or Mega 2560
Arduino Mega ADE
Arduine Leonardo
Arduine Leonarde ETH
Arduino/Genuine Micro
Arduino Esplora
Arduing Mini
Arduino Ethernet
Arduino Fio
Arduino BT
LilyPad Arduino USE
LilyPad Arduinc
Arduing Pro or Pro Mini
Arduine NG or clder
Arduino Robot Control
Arduine Robot Motor



File Edit Sketch |Tools| Help

Auto Format Ctrl+T
Archive Sketch
sketch_sep26; Fix Enceding & Reload
vold setup() Serial Monitor Ctrl+Shift+M
/1 pat yeus Serial Plotter Ctrl+Shift+L
! WiFi101 Firmware Updater
void loop() | Board: "Arduino/Genuino Uno" J
rr t your
£ BEE e Port: "COM1" v
1 Get Board Info
Programmer: "Arduincl5P" ' AVR ISP
Burn Bootloader AVRISP mikll

USBtinyl5P
IEI Arduinol5P
Arduinol5P.org
USBasp
Parallel Programmer
Arduine as ISP
Arduinoe Gemma
BusPirate as [SP
Atmel 5TKS00 development board
Atmel JTAGICES (ISP mode)
Atmel JTAGICES (JTAG mode)
Atmel-1CE (AVR)

nuino Uno on COM

Select the programmer Arduino ISP, if this is not selected must select the Arduino ISP
programmer . after connecting the Arduino must select the COM port.



Blink a Led

Connect the board to the computer. In the Arduino, software go to
File -> Examples -> Basics -> Blink LED. The code will automatically load in the window.

Elink &

Blink
Turns on an LED on for one 3econd, then off for one asecond, repeatedly.

Moat Arduinocs have an on-board LED you can control. On the UHO, MEGRE and ZERD
it is attached to digital pin 13, on MER1O000 on pin &. LED BUILTIN is set to
the correct LED pin independent of which board iz used.

S/ the setup function runs once when you press gesetworipower the board
wold setup() |

ff initialize digital pin LED BUTLTIN as fan output.

pinMode (LED BUILTIN, OUIEUT):

}
S/ the loop function runs overiand, over again forewver
wold loop() |
digitalWrite (LED BULLTEW, HIEH) 7 /4 turn the LED on (HIGH is the woltage lew
delay (1000} ; f/ walit for a second
digitalWrite (LED BUILTIN, LOW); S/ turn the LED off by making the woltage 1
delay (1000} ; S/ wait for a second
}
W
£ >

Arduine/Genuino Uno an COM3

Press the Upload button and wait until the program says Done Uploading. You should see the
LED next to pin 13 start to blink. Note that there is already a green LED connected to most
boards — you don’t necessarily need a separate LED.



Troubleshooting

If you are not able to upload any program to Arduino Uno and getting this error for "BLINK"
While uploading Tx and Rx blinks;simultaneously and generate the message

avrdude: verification error, first mismatch at byte 0x0000

0x0d != 0x0c

Avrdude verification error; content mismatch

Avrdudedone “Thank you'

Blink &

= on an LED on for one second - then off for one second ;s LEpEAT edl Ve

This exanple code 15 in the public domain.

A

/7 Pin 13 has an LED commected on most Arduino boards.
A/ give 1t a name:
int led = 3;

A/ the setup routing runs once yhHen you preéss reset:
volid setup () {
initialize the digitalfpin as &R ouUCPUL:
pinMode (led, OUTPUT):

/f the loop routine runs over and over again forewver:

wold loop () {
digitalWrite(led, HIGH) : f turn the LED on (HIGH iz the voltage lewel)
delay(1000) : f wait for a second
digitalWrite(led, LOW): f turn the LED off by making the wvoltage LOW
-".-'-'..':‘_'r‘lilEIEIU]: f wait for a second




Suggestion

e Make sure you have the right item selected in the Tools > Board menu. If you have an
Arduino Uno, you'll need to choose it. Also, newer Arduino Duemilanove boards come
with an ATmega328, while older ones have an ATmegal68. To check, read the text on
the microcontroller(the larger chip) on your Arduino board.

e Check that the proper port is selected in the Tools > Serial Port menu (if your port
doesn't appear, try restarting the IDE with the board connected to the computer). On
the Mac, the serial port should be something like /dev/tty.usbmodem621 (for the
Uno or Mega 2560) or /dev/tty.usbserial-A02f8e (for older, FTDI-based boards). On
Linux, it should be /dev/ttyACMO or similar (for the Uno or Mega 2560) or
/dev/ttyUSBO or similar (for older boards).

e On Windows, it will be a COM port but you'll need to check in the Device Manager
(under Ports) to see which one. If you don't seem to have a serial port for your
Arduino board, see the following information about drivers.

Drivers

e _On Windows 7 (particularly the 64-bit version), you-might need to go into the Device
Manager and update the drivers for the Unoor-Mega 2560.

£ Device Manage” T

File Action View Help
&= | T & HE & %S

4 =4 REES52-PC
78 Computer

- w—m Disk drives
B Display adapters
b %% Human Interface Devices
<@ IDE ATA/ATAPI controllers
. == Keyboards
vv)fs Mice and other pointing devices
. i Monitors
-®¥ Network adapters
4 - [l5, Other devices
-l Ethernet Controller
i |l Universal Serial Bus (USB) Controller
4 7% Ports (COM & LPT)

: e -3 - iy
i & Ardui Update Driver Software... RIGHT CLICK
C D Processol :

% Sound, vi Disable

&5 Storage c Uninstall

;M System d

2 i Scan for hardware changes
- @ Universal

Properties




Just right click on the device (the board should be connected to your computer), and
point Windows at the appropriate .inf file again. The .inf is in the drivers/ directory of
the Arduino software (not in the FTDI USB Drivers sub-directory of it).

If you get this error wheniinstalling the Uno or Mega 2560 drivers on Windows XP:
"The;system cannot find the file specified

On Linux, the Uno and Mega 2560 show up as devices of the form /dev/ttyACMO.
These are not supported by the standard version of the RXTX library that the Arduino
software uses for serial communication. The Arduino software download for Linux
includes a version of the RXTX library patched to also search for these /dev/ttyACM*
devices. There'salso an Ubuntu package (for 11.04) which includes support for these

devices. If, however, you're using the RXTX package from your distribution, you may
need to symlink from /dev/ttyACMO to
/dev/ttyUSBO (for example) so that the serial port appears in the Arduino software

Run

sudo usermod -a -G tty yourUserName
sudo usermod -a -G dial out yourUserName
Log off and log on-again for the changes to take effect.

Access to the Serial Port

On Windows, if the software is slow to start or crashes onlaunch, or the Tools menu
is slow to open, you may need to disable Bluetooth serial ports or other networked
COM ports in the Device Manager. The Arduino software scans all the serial (COM)
ports on your computer when it starts and when you open the Tools menu, and these
networked ports can sometimes cause large delays or crashes.

Check that you're not running any programs that scan all serial ports, like USB Cellular
Wi-Fi Dongle software (e.g. from Sprint or Verizon), PDA sync applications, Bluetooth-
USB drivers (e.g. BlueSoleil), virtual daemon tools, etc.

Make sure you don't have firewall software that blocks access to the serial port (e.g.
ZoneAlarm).

You may need to quit Processing, PD, vvvy, etc. if you're using them to read data over
the USB or serial connection to the Arduino board.

On Linux, you might try running the Arduino software as root, at least temporarily to
see if fixes the upload.


https://launchpad.net/ubuntu/+source/rxtx/2.2pre2-3

Physical Connection

First make sure your board is on (the green LED is on) and connected to the
computer.
The Arduino Uno .and Mega 2560 may have trouble connecting to a Mac through a

USB hub. If nothing appears.in your "Tools > Serial Port" menu, try plugging the board
directly to your computer and restarting the Arduino IDE.

Disconnect digital pins 0 and 1 while uploading as they are shared with serial
communication with the computer (they can connected and used after the code has
been uploaded).

Try uploading with nothing connected to the board (apart from the USB cable, of
course).

Make sure the board isn't touching anything metallic or conductive.

Try a different USB cable; sometimes they.don't work.

Auto reset

If you have a-boardthat doesn't supportauto-reset, be sure that you are resetting the
board a couple-of seconds before uploading. (The Arduino Diecimila, Duemilanove,
and Nano-support auto-reset as do the LilyPad, Pro, and Pro Mini with 6-pin
programming headers).

However, note that some Diecimila were accidently burned with the wrong
bootloader and may require you to physically press the reset button before
uploading.

However, on some-computers, you may needto press the reset button on the board
after you hit the upload button in the Arduino environment. Try different intervals of
time between the two, up to 10'seconds or more.

If you get this error: [VP 1]Device is not responding correctly. Try uploading again (i.e.
reset the board and press the download button a second time).
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Boot loader

e Make sure there's a bootloader burned on your Arduino board. To check, reset the
board. The built-in LED (which'is.connected to pin 13) should blink. If it doesn't, there
may not be a bootloader on your board.

¢ What kind of board you have. If it's a Mini, LilyPad or other board that requires extra
wiring, include a photo of your circuit, if possible.

o Whether or not you were ever able to upload to the board. If so, what were you doing
with the board before / when it stopped working, and what software have you
recently'added or removed from your computer?

o The messages displayed when you-try to upload with verbose output enabled. To do
this, hold down the shift key while clicking on the upload button-in-the toolbar.



